vmrun issue on VMware Workstation 7.1.0

By | July 29, 2010

I was working on a specialized project that included the use of vmrun (part of VMware VIX).

The Project
This project required the ability to restore a VM to a baseline Snapshot.

The challenge is that the user is not a tech person, and the requirement was that it was very easy to restore the baseline Snapshot using a simple batch file.

The Problem
So I ran vmrun (located in C:Program FilesVMwareVMware VIX) to see the necessary syntax to revert to a Snapshot.

The syntax is:
vmrun -T ws revertToSnapShot “C:pathvmnamevmname.vmx” SnapShotName

The error I received “was: The specified version was not found”

After some looking around, it appeared that one of two things happened:

  1. The updated VMware VIX package was not updated from my 7.0.1 installation of VMware Workstation
  2. The updated VMware VIX package was not included in the 7.1.0 installation of VMware Workstation.

I kind of think that the first is true.  I say this, because when VMware Workstation is initially installed, a VMware VIX installer presents itself to augment the installation.

The Solution
I went to VMware’s site to download the latest version of VMware VIX.
http://communities.vmware.com/community/developer/forums/automationapi

After installing the updated VMware VIX build, my problems were solved.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.